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Preface

This manual describes the use of the NXP MCUXpresso Integrated Development
Environment (IDE) to develop applications for the NXP JN518x family of wireless
microcontrollers.

“ Note: MCUXpresso is fully detailed in its own documentation
set, available from the NXP web site (See Support Resources on

page 5).

This manual (JN-UG-3136) provides additional information needed to
develop JN518x applications within MCUXpresso.

Organisation

This manual consists of three chapters and four appendices, as follows:

Chapter 1 introduces MCUXpresso and provides installation instructions for
the plug-ins that are required for developing JN518x applications

Chapter 2 describes how to import IN518x application in MCUXpresso
starting from an NXP Application Note

Chapter 3 describes how to debug a running JN518x application via
MCUXpresso

The Appendices contain information and procedures that may be useful in
using MCUXpresso

Conventions
Files, folders, functions and parameter types are represented in bold type.
Function parameters are represented in italics type.

Code fragments are represented in the Courier typeface.

= This is a Tip. It indicates useful or practical information

“ This is a Note. It highlights important additional information.

4 © NXP Semiconductors 2018 JN-UG-3136 v1.0
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AThis is a Caution. It warns of situations that may result in
equipment malfunction or damage.

Acronyms and Abbreviations
Definitions of acronyms and abbreviations should follow the following format:
IDE Integrated Development Environment
SDK Software Developer’s Kit

Related Documents
The list of related documents should follow the following format:
JN518x Datasheet (JN-DS-JN5189)
MCUXpresso IDE User Guide
MCUXpresso Installation and Licencing Guide
MCUXpresso IDE SWO Trace Guide

Support Resources

To access online support resources such as SDKs, Application Notes and User
Guides, visit the Wireless Connectivity area of the NXP web site:

www.nxp.com/products/interface-and-connectivity/wireless-connectivity

All NXP resources referred to in this manual can be found at the above address,
unless otherwise stated.

MCUXpresso and its documentation are available from:

WWW.NXP.com/mcuxpresso

For information on obtaining and installing the appropriate version of
MCUXpresso to develop applications for IN518x chips, refer to Section 1.2

Trademarks

All trademarks are the property of their respective owners.
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1 Introduction and Installation

The NXP MCUXpresso Integrated Development Environment (IDE) is employed
as a platform for the development of wireless network applications to be run on
NXP’s JN518x family of wireless microcontrollers. MCUXpresso is an Eclipse-
based IDE that provides editing, compiling, debug and Flash programming
functionality.

For information on how to obtain and install MCUXpresso along with the IN518x
stack libraries, refer to Section 1.1.

1.1 MCUXpresso for JN518x Installation

It is recommended that before first installing MCUXpresso the user first installs
the JN518x stack libraries SDK. This is so that the required workspaces are
created.

Installation steps:

1. Download the JN518x stack libraries SDK installer (for example the JN-SW-
4470 JN518x Zigbee 3.0 vXXXX.exe). These SDK’s are distributed as a self-
extracting executable.

2. Launch the JN518x stack libraries SDK executable in to a convenient location,
such as C:\NXP\mcux. This SDK contains the device drivers, framework,
connectivity stack along with example projects.

3. Download MCUXpresso — see Sectionl.2. MCUXpresso toolchain must be
installed at the same location as the JN518x stack libraries SDK. Launch the
MCUXpresso installer and follow the on-screen instructions to install.

4. After installing the SDK and MCUXpresso IDE you should have the directory
structure shown below:

» Computer » AWS System (C) » NXP » mcux b v |42 [| Search mcux yel

Organize » Include in library = Share with ¥ New folder = i e
Favorites i Name Date modified Type Size

IN-SW-4470 20/07/2017 18:57 File folder
M Desktop MCUXpressolDE_10.0.0_344 18/07/2017 13555 File folder
. Libraries

*, Documents
= Git

4, Music

&, Pictures

.. Subversion
Q Videos
R Faisal Bhaiyat

n

& Computer

5. To add JN518x support to MCUXpresso it is necessary to add a number of files
to the installation. These files are provided within the SDK which was installed
during step 2. These can be found in the following folder

‘C:\ANXP\mcux\JN-SW-4470\tools\Ipcxpresso\bin’

6. Copy the ‘C:\NXP\mcux\JN-SW-4470\tools\Ipcxpresso\bin’ folder to
‘C:\NXP\mcux\MCUXpressoIDE_10.1.1_606\ide’. There should already be a
‘bin’ folder there and the copied version should be merged with it. If using
Windows Explorer to copy the folder across, Windows will complain that it is

6 © NXP Semiconductors 2018 JN-UG-3136 v1.0



JN518x MCUXpresso
Installation and User Guide

there already: this is correct, so click ‘Yes’ and/or ‘Copy and Replace’ as
required.

A Caution: Note that using the command line to copy the files
may incorrectly set the access permissions whereas CTRL-C and
CTRL-V in Windows Explorer work fine

7. Run ‘mcuxpressoide.exe’ and select a folder to use as Workspace. This should
be the folder where the SDK was installed

‘C:ANXP\mcux\JN-SW-4470\workspace’.

8. JN518x bootloader requires an image signature to verify the validity of the
image. The Binary image generated is signed after the image is built in a two-
stage process. The image signing tool is implemented in python. This requires
an installation of python to exist. Python 2.7 is required.

Python can be downloaded from the following web page:
https://www.python.org/downloads/
Once python is installed, it should be added to the windows path.

9. The python file is now using a crypto module; therefore, you may have to install
the module to compile successfully:

C:\Python27\Scripts>pip install pycryptodome

(python 2.7.13 (https://lwww.python.org/downloads/release/python-2713/) is
required to have the pip tool)

10. The JN518x Application Notes are not provided as part of the JIN518x stack
libraries SDK. They are provided separately as ZIP files. The Application Notes
should be extracted into the workspace created in step 7.

‘C:ANXP\mcux\JN-SW-4470\workspace’

The directory structure may look like this:

e ‘ ‘ » Computer » AWS System (C) ¥ NXP » mcux » JN-SW-4470 » workspace » H Search workspace
Organize*  Includeinlibrary > Sharewith >  New folder E= _J Q
Favorites Name Date modified Type Size
‘metadata 20/07/201719:08  File folder
I Deskiop 0 AT-ZCPIN518x 19/07/2017 1048 File folder
J Libraries § AT-ZI0 19/07/2017 1049 File folder
- Documents 0 IN-AN-1243-ZigBee-3-0-Base-Device-Template-for-JN518x 19/07/201710:43  File folder
= Gt 0 IN-AN-1244-ZigBee-3-0-Light-Bulb 18/07/201717:54  File folder
4 Music O IN-AN-1245-ZigBee-3-0-Controller-and-Switch-for-JN518x 19/07/201710:50  File folder
= Pictures 0 IN-AN-1246-ZigBee-3-0-Sensors-for-IN318x 19/07/201710:50  File folder
 Subversion © IN-AN-1247-ZigBee-3-0-loT-Control-Bridge-for-IN518x 19/07/2017 1404 File folder

i/ Videos
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1.2 MCUXpresso Installation
MCUXpresso can be obtained from the following NXP web page:
http://www.nxp.com/mcuxpressol/ide

A Caution: The recommended version of MCUXpresso to
be used with an SDK can be found in the JN518x SDK Release
Notes. This is the version with which the libraries within the SDK
were compiled and verified. Other versions of MCUXpresso may
not be compatible with the contents of the SDK and cannot be
guaranteed to work or be supported with the JIN518x devices.

To obtain MCUXpresso and install it on your development machine:

1. If you do not already have a web account with NXP, navigate to
www.nxp.com and create an account.

Sign in to your NXP web account.
Navigate to the page www.nxp.com/mcuxpresso/ide
Select the Downloads tab and then click the Download button.

Check whether the displayed version is the recommended version
indicated above:

¢ If it is the recommended version, download it.

o bk~ 0D

¢ |If it is not the recommended version, click Previous and then select the
recommended version and download it.

Full installation details are provided in the MCUXpresso IDE Installation and
Licensing Guide, available on the Documentation tab of the above web page.

< Tip: To develop JN518x applications without limitation we
recommend that you purchase the Pro edition of MCUXpresso,
however, with the free edition you can develop with applications up to
256KB

8 © NXP Semiconductors 2018 JN-UG-3136 v1.0
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1.3 Installation of ZPSConfig plugins:

The Zigbee 3.0 stack configuration plugins have been updated to be hosted as

part of the MCUXpresso IDE.

The plugins and features can be found located in the SDK folder structure as

below:;
C:\ANXP\mcux\JN-SW-

4470\tools\zighee_3.0\Eclipse_plugins\com.nxp.sdk.update_site

To add the plugins

1. On the top menu pane of the MCUXPresso select the Help->Install New

Software option.

[Help]
4| @ Help Contents
Bl MCUXpresso IDE User Guide
% Search

Show Contextual Help

file Edit Navigate Search Project Run FreeRTOS Window
{50 | ® ~ & v iw | - 1

RPr. ® = 0O = fsl_ginth (g
E =2 - file

G5 JN-AN-1243-Zigbee-3-0-Base-Device L Rioe e hiinge

Tips and Tricks..

Cheat Sheets...

Ctrl+Shift+L

@4 Install New Soﬁware.‘[
® Details
“% Check for Updates

Install New Software.. |

* Additional resources
¢ Display license type
® Product Information
® support

* Pro Edition

B® About MCUXpresso IDE

Quick Access.

8 | (&)

S

- B

JregisteredProEdition.htm

X

E (Pro Edition) is fully activated

(Pro Edition). The software Is now tully activated

Buide provides instructions for using MCUXpresso

This is also available from the Help menu.
Guide

Help->Help Contents

i provided within the MCUXpresso IDE via the Help menu:

VQ i« (=]

P Mcuxpresso IDE (Pro Edit

@ Console
| No consoles to display at this time.

~ Start here
B New project.
& import SDK

ple(s).

® Import project(s) from file system,

< il »

- A 1l 1t To € 1 tB@ =0

File gate Search

Project Run FreeR]

Available Software
{5, | ® ] ~v@in| LR

Select a site or enter the location of a site.
BPr. 2 ||

(5 JN-AN-1243-Zigbee-3-0-Base-Device Workwith: | type or select a site

type filter text

Name: NXP ZPS Config for Zigbee 3,0

[ssean ]

Details

[¥] Show only the latest versions of available software
wQ 8 ® 77 [} |¥| Group items by category
"] Show only software applicable to target environment

PR Mmcuxpresso IDE (Pro Edi("‘ [7] Contact all update sites during install to find required software
~ Start here |
|| Nod|

B New project.

B8 import SDK example(s) @

® Import project(s) from file system

Find more software by working with the "Available Software Sites” preferences. | |-

|| Location: file:/C:/NXP/mcux/IN-SW-4470/tools/zigbee_3.0/Eclipse_pluc Archive...

s Quick Access || & |[R)
S
e [ =Adds, J o

Version

Local...

elp menu

{

Cancel

[¥] Hide items that are already installed

What is already installed?

v EvMNv©eO

Cancel

)

P

< il »

Done

JN-UG-3136 v1.0
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Give the plugins a Name. This can be anything. Select the local button
and browse to the location of the plugins which should be

C:/NXP/mcux/IN-SW-
4470/tools/zigbee_3.0/Eclipse_plugins/com.nxp.sdk.update_site/

3. This should pull the available features to install;

=
Available Software :
(m R S Qv - 0 . Quick Access :| B | (K]
» Check the items that you wish to install. Jf
@yPro.. 22 | % Per.. HifRe. #iSy.~ O i =0
o - 803 x
4 G5 JN-AN-1243-Zigbee-3-0-Base-Device 63|f| Work with: NXP ZPS Config for Zigbee 3.0 - file:/C:/NXP/mcux/JN-SW-4470/tools/zigbee_3.0/Eclipse_plugins/com.nx; v Add...
> % Binaries 2 “: | Find more software by working with the "Available Software Sites” preferences.
> G Common Z ¥ .
o type filter text
(@& Coordinator 64
» & EndDevice 64l Name Version
+ Ga Router [@odfll| 4+ [¥]mn NXP ZBPro SDK
64 [#]4* NXP ZBPro Configuration Editor 201
64
64
64
64
64
65)
69)
69)
65} = =
ZS Select All ‘ Deselect All 1 item selected e
69) -
55 Details
63)
69)
65l . =
26 [] Show only the latest versions of available software [v| Hide items that are already installed
O Q. R WG B 0= 8 | 66l [¥] Group items by category What is already installed?
cofll
; || Show only software applicable to target environment =
& MCUXpresso IDE (Pro Edit, :‘ [¥] Contact all update sites during install to find required software " »
“BvHNv=0
~ Start here

B New project..
B8 import SDK example(s).

Cancel

& Import project(s) from file system...
LY

e

<] i ] »

0 items selected ‘O workspace

4. Select the features listed and then press the “Next” button. Accept the
subsequent Licence agreement and warning of Signature validation. Then
press the “Finish” button and let MCUXpresso restart.

5. If the plugins have been successfully installed it will be listed in the
“already installed” software list.

10 © NXP Semiconductors 2018 JN-UG-3136 v1.0
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2 Importing Projects into MCUXpresso

To import the example projects into MCUXpresso, click File -> Import... This will
bring up a dialogue box.

Select General -> Existing Projects into Workspace, then press ‘Next’:

Select \

Create new projects from an archive file or directary.

Select an import wizard:

type filter text

L= Existing Projects into Workspace o
[ File System
5 Import projects(s) from XML description
[C] Preferences
3 Projects from Folder or Archive

s CfCH++

> = CVS

> B Git

> = Install -

m

The next dialogue box allows you to select the location that the projects can be
found at. ‘Select root directory’ will already be selected.

Click the ‘Browse...." Button to the right and then navigate to the folder where the
SDK was installed. Navigate further into ‘C:\NXP\mcux\JN-SW-
44XX\workspace’ then press ‘OK’.

Back in the original dialogue box ensure that ‘Copy projects into workspace’ is
not selected, then press ‘Finish’,

The projects will now appear in the Projects Explorer panel. To build one, select
it and press the build button on the toolbar (looks like a hammer).

JN-UG-3136 v1.0 © NXP Semiconductors 2018 11
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3 Debug Configuration

It is possible to flash the image for the IN518x by using the SWD (Single Wire
Debug) functionality available in MCUXpresso.

Select the dropdown menu next to the “bug” symbol on the selection panel of
MCUXpresso IDE.

Select “Debug Configuration”.

file Edit Navigate Search Project Run FreeRTOS Window Help

v DR R S [S£pHRRBR L P AF O U Gid e ——

P o | Pes PR s @ Welcome:
s@ - ® 5 fle///C/NYP/max/MCUXpressalDE 100]  DEPUIAS
& IN-AN-1243-Zigbee-3-0-Base-Device] Debug Configurations...

Organize Favorites...

MCUXpresso IDE (Pro Edition) is fully activated

The MCUXpresso IDE User Guide provices InStructions 10r using MCUXprEsso This S aiso avaiiable from the Help menu
Help->MCUXpresso User Guide

Further product documentation s provided within the MCUXpresso IDE via the Help menu

Help->Help Contents

vQ & ]

R mcuXpresso IDE (Pro Edit~

© Console ¢
—| No consoles to display at this time.

5 JN-AN-1243-Zigbee-3-0-Base-Device

The selection would bring up a pop up configuration box.

On the left-hand pane select the C/C++ NXP MCU Application and right click.
That should provide drop down options, from the list select “New”.

O NXP IN5189 ON-AN-1243-Z..-Base-Device)

Xl workspace - Dev a
File Edit Navigate Search Project Run

E5Pr. %X ZPe. #iRe. LiSy. = %I Create, manage, and run configurations ﬁ\'
SER|

» 5 IN-AN-1243-Zigbee-3-0-Base-Device||

Quick Access | & | )
=0

-> B

G [IEER

Configure launch settings from this dialog
type filter text o
B8 C/C++ (NXP Semiconductors | =
€] ¢/C+ + Application ) - ErE T T re selected confi
] C/C+ Attach to Application - Press the "Delete’ button to remove the selected configuration.

- Press the New’ button to create a configuration of the selected type.

| - Press the ‘Duplicate’ button to copy the selected configuration

[E] C/C++ Postmortem Debugge | = - Press the 'Filter' button to configure filtering options.
[E] C/C++ Remote Application
[£] GDB Hardware Debugging
[ GDB PEMicro Interface Debur
8 6B Seqger Interface Debug | COMfIgure [2unch perspective settings from the Perspectives preference page.
# Launch Group

- Edit or view an existing configuration by selecting it

< I ] D

0Q B ®»G v B o = G| Filter matched 9 of 9 items

MCUXpresso IDE (Pro Editf] 7 Debug

~ Start here

St “@v@vy-o
No consoles to display at this time

m

B New project

B8 Import SDK example(s)...

& Import project(s) from file system... —
A Build UN-AN-1243-Zigbee-3-0-Base-
& Clean IN-AN-1243-Zigbee-3-0-Base-

# Debug N-AN-1243-Zigbee-3-0-Base
A T— v

=5 IN-AN-1243-Zigbee-3-0-Base-Device O NXP N5189 (N-AN-1243-7..-Base-Device)

12 © NXP Semiconductors 2018 JN-UG-3136 v1.0
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The subsequent pop up configuration box allows creating a debug configuration
for the current build configuration.

In the Name box type a name of your choice for your current configuration. E.g.
JN-AN-1243-Zigbee-3-0-Base-Device Coordinator

For the C/C++ Application box, use the browse button to find the “.axf” file for the

image you want to debug/Flash.

e.g. C:\NXP\mcux\IJN-SW-4470\workspace\JN-AN-1243-ZigBee-3-0-Base-
Device-Template-for-JN518x\Coordinator\Build\jn518x_mcux\
Coordinator_JN5180 DONGLE.axf

For the build configuration, use the dropdown menu to select “Use Active”. Then
save the changes by pressing the “Apply” button.

B workspace - D

evel

- Welcome page - MCUXpresso D!

File Edit Navigate Search Project Run g

[5pr.. %% Pe. WHRe. &Sy. Create, manage, and run configurations ﬁ\
eE {

» 8 IN-AN-1243-Zigbee-3-0-Base-Devicel

wQ ®

P Mcuxpresso IDE (Pro Edit{

~ Start here

B New project.

2 *‘ B~ Name: JN-AN-1243-Zigbee-3-0-Base-Device Coordinator

type filter text
4 B8 C/C++ (NXP Semiconductors
38 JN-AN-1243-Zigbee-3-0-F

€] C/C++ Application IN-AN-1243-Zigbee-3-0-Base-Device
[] C/C++ Attach to Application ||| ¢/c++ Application:
[£] C/C++ Postmortem Debugge
[E] C/C++ Remote Application
[£] GDB Hardware Debugging I Variables... ] l Search Project... ] l Browse. I
[ GDB PEMicro Interface Debui || Build (if required) before launching
[ GDB Segger Interface Debug

[E Main % Debugger| i Source| £ Common

Project:

CANXPYymeux\JN-SW-4470\workspace\JN-AN-1243-ZigBee-3-0-Base-Device-Template-for-JN518x\Coordinator\Bu

Build Configuration: |Use Active ']
¥ Launch Group Use active build configuration |
_) Enable auto build ~rOisable auto build
(@) Use workspace settings Configure Workspace Settings..
<[ m »
= || Fitter matched 10 of 10 items Apply
@' [ Debug l l Close ]

No consoles to display at this time.

1

B 1mport SDK example(s).

& Import project(s) from file system...
% Build IN-AN-1243-Z gbee-3-0-Base-|
¢ Clean 'IN-AN-1243-Z igbee-3-0-Base-
¥ Debug 'JN-AN-1243-Zigbee-3-0-Base

< 1

D

(% JN-AN-1243-Zigbee-3-0-Base-Device

1

Quick Access || & |[X)

= B8

- B

O NXP JN5189 (JN-AN-1243-Z..-Base-Device)

In the Debug Configuration pop up window, the Debugger needs to be
configured.

Select the “Debugger” Tab.

This should update the existing Debug configuration pop up window with the
possible configurations for the Debugger.

Tick the option for “Stop on startup at” and in the box type “main”.
Update the “Connect script” to be “JN518xConnect.scp”.

The “Emulator Selection” needs to be “LinkServer” and the “Debug options
template” is “NXP JN5189 (*)”

To save these settings press “Apply”.

Now just press “Debug” and connect your board if not already connected. The

board will be programmed with the image and this should allow a debug session
to be started.

JN-UG-3136 v1.0 © NXP Semiconductors 2018 13
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= -

File Edit Navigate Search Project Run

IBrHQ B R r@Bie|® Debug Configuratio Quic e 2|
Bypr. 2% Pe. HiRe. £ISy. ° Create, manage, and run configurations =g
E | @ (Main]: Program not specified - B
i % JN-AN-1243-Zigbee-3-0-Base-Device
0@ xl B~ Name: JN-AN-1243-Zigbee-3-0-Base-Device Coordinator
type filter text Main % Debugger & Source| ] Common|
4 @ C/C++ (NXP Semiconductars Op On startup at: - main [T Force haraware n
& Debugger Options T
[£] C/C++ Application » m
[E] C/C++ Attach to Application
(2] C/C++ Postmortem Debugge Debug options for NXP JN5189 (cartex-m4)
(2] C/C++ Remote Application
Debug Ce cti SWD ~ | |EditJTAG fi ti 3
<] GDB Hardware Debugging ebug tennection ST 2
[ GDB PEMicro Interface Debur Configuration Option = Value
A GDB Segger Interface Debug i Additional aptions
¥ Launch Group [ Attach only False
«i: Connect Script INS18xConnectscp
«f: Debug Level 2
[ Nicrnnnort hohauin: cont =
Miscellaneous
Ernulator calact &
« il »
©Q B WG WV %8 o = O Fitermatched 10 of 10 items REvert Apply
MCUXpresso IDE (Pro Edit
Search #EB->3~v=n0o
~ Start here
No consoles to display at this time.
B New project...
B import SDK example(s)

@ Import project(s) from file system.

A Build ‘JN-AN-1243-Zigbee-3-0-Base-
o Clean 'JN-AN-1243-Zigbee-3-0-Base-
% Debug N-AN-1243-Zigbee-3-0-Base

4 m »

(5 JN-AN-1243-Zigbee-3-0-Base-Device Y NXP JN5189 IN-AN-1243-Z..-Base-Device)

By default, there are no debug symbols present so it's possible that no source
code would be presented when running a debug session.

To build with debug symbols, the following needs to be added to the Makefile
“‘DEBUG=HW” and a clean build of the application is now required.

14 © NXP Semiconductors 2018 JN-UG-3136 v1.0
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Important Notice

Limited warranty and liability — Information in this document is believed to be accurate and reliable. However,
NXP Semiconductors does not give any representations or warranties, expressed or implied, as to the accuracy
or completeness of such information and shall have no liability for the consequences of use of such information.
NXP Semiconductors takes no responsibility for the content in this document if provided by an information source
outside of NXP Semiconductors.

In no event shall NXP Semiconductors be liable for any indirect, incidental, punitive, special or consequential
damages (including - without limitation - lost profits, lost savings, business interruption, costs related to the
removal or replacement of any products or rework charges) whether or not such damages are based on tort
(including negligence), warranty, breach of contract or any other legal theory.

Notwithstanding any damages that customer might incur for any reason whatsoever, NXP Semiconductors’
aggregate and cumulative liability towards customer for the products described herein shall be limited in
accordance with the Terms and conditions of commercial sale of NXP Semiconductors.

Right to make changes — NXP Semiconductors reserves the right to make changes to information published
in this document, including without limitation specifications and product descriptions, at any time and without
notice. This document supersedes and replaces all information supplied prior to the publication hereof.

Suitability for use — NXP Semiconductors products are not designed, authorized or warranted to be suitable
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